易语言

易语言异常捕获使用教程①

奶瓶 · 8月5日 · 2020年 · · 8次已读

异常捕获之易语言程序异常关闭,怎么保存内存或界面中的数据呢?

使用异常捕获模块,可以在程序出现异常时通知到指定函数,从而在奔溃前,保存你所需要的数据。当然也可以用作异常分析标记等。能然你知道是那句代码引起的程序崩溃,从而针对解决问题。

代码示例:

.版本 2

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行

异常辅助_开始截获 (&异常通知, , 真, , , , , , , , )  ' 开启异常捕获,请在程序入口最先初始
写到内存 (-10, 2, 222)  ' 模拟异常

返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 异常通知

信息框 (“发现程序异常!”, 0, , )

易语言源码
例子源码
异常弹窗
异常通知
异常捕获详细
异常捕获详细

例子源码,模块下载

0 条回应